# \[COMPRESS\_ERROR\] server pushed compression settings that are not allowed

**URL:** <https://forum.pritunl.com/t/compress-error-server-pushed-compression-settings-that-are-not-allowed/1584>\
**Category:** Pritunl\
**Tags:** pritunl\
**Created:** [November 28, 2023, 2:18pm UTC](https://forum.pritunl.com/t/compress-error-server-pushed-compression-settings-that-are-not-allowed/1584 "2023-11-28T14:18:05Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![mnk0004](https://forum.pritunl.com/letter_avatar_proxy/v4/letter/m/e495f1/32.png) [@mnk0004](https://forum.pritunl.com/u/mnk0004)\
**Post date:** [November 28, 2023, 2:18pm UTC](https://forum.pritunl.com/t/compress-error-server-pushed-compression-settings-that-are-not-allowed/1584/1 "2023-11-28T14:18:05Z")

</div>

Hello! When i tried to connect to pritunl-server from openvpn3, i have this message:  
session-start: \*\* ERROR \*\* Failed to connect: Connection, Client disconnected

$ openvpn3 session-start --config local\_vpn.ovpn  
$ Using configuration profile from file: local\_vpn.ovpn  
$ Session path: /net/openvpn/v3/sessions/f943f16ds7131s49e1s9023s0983a5d60ef8  
$ session-start: \*\* ERROR \*\* Failed to connect: Connection, Client disconnected

$ sudo openvpn3-admin journal --path /net/openvpn/v3/sessions/f943f16ds7131s49e1s9023s0983a5d60ef8  
$ [sudo] пароль для admin:  
$ Tue Nov 28 17:10:13 2023 {tag:2360436534705743513} Client **!! FATAL !!** : [COMPRESS\_ERROR] server pushed compression settings that are not allowed and will result in a non-working connection.

can somebody help me??

---

<div class="post-metadata">

**Author:** ![VicktorSimonov](https://forum.pritunl.com/user_avatar/forum.pritunl.com/vicktorsimonov/32/681_2.png) [@VicktorSimonov](https://forum.pritunl.com/u/VicktorSimonov)\
**Post date:** [January 5, 2024, 7:47pm UTC](https://forum.pritunl.com/t/compress-error-server-pushed-compression-settings-that-are-not-allowed/1584/2 "2024-01-05T19:47:30Z")

</div>

Hello. follow this step:

1. import config  
$ openvpn3 config-import --config config\_vpn.ovpn --name MY\_VPN1
2. allow compression  
$ openvpn3 config-manage --config MY\_VPN1 --allow-compression yes
3. connect to vpn  
$ openvpn3 session-start --config MY\_VPN1

---

<div class="post-metadata">

**Author:** ![mohsen.sh](https://forum.pritunl.com/letter_avatar_proxy/v4/letter/m/5f9b8f/32.png) [@mohsen.sh](https://forum.pritunl.com/u/mohsen.sh)\
**Post date:** [January 24, 2024, 1:19pm UTC](https://forum.pritunl.com/t/compress-error-server-pushed-compression-settings-that-are-not-allowed/1584/3 "2024-01-24T13:19:38Z")

</div>

thaaaaaaank you, this worked for me

---

<div class="post-metadata">

**Author:** ![mjaggard](https://forum.pritunl.com/user_avatar/forum.pritunl.com/mjaggard/32/413_2.png) [@mjaggard](https://forum.pritunl.com/u/mjaggard)\
**Post date:** [June 18, 2024, 9:42pm UTC](https://forum.pritunl.com/t/compress-error-server-pushed-compression-settings-that-are-not-allowed/1584/4 "2024-06-18T21:42:12Z")

</div>

This is the wrong solution for two reasons. 1. Compression has been disabled by default for a good reason - it can be used as an attack vector. 2. Not all clients allow changing these settings - I can’t see any way to change settings in OpenVPN Connect on android for example.

What’s the proper fix for this? I can’t see any way to disable compression in the Pritunl UI.

---

<div class="post-metadata">

**Author:** ![zach](https://forum.pritunl.com/user_avatar/forum.pritunl.com/zach/32/1105_2.png) [@zach](https://forum.pritunl.com/u/zach)\
**Post date:** [June 19, 2024, 6:20am UTC](https://forum.pritunl.com/t/compress-error-server-pushed-compression-settings-that-are-not-allowed/1584/5 "2024-06-19T06:20:01Z")

</div>

There is no option to enable compression, in very old releases there was an option but it is no longer shown and disabled by default. Enabling debugging output in the server settings will show the server configuration in the output when starting. The line `allow-compression no` would indicate it is disabled. Chrome Developer Tools could also be used to view the response from the server page and check the value of `lzo_compression`.

---

<div class="post-metadata">

**Author:** ![mjaggard](https://forum.pritunl.com/user_avatar/forum.pritunl.com/mjaggard/32/413_2.png) [@mjaggard](https://forum.pritunl.com/u/mjaggard)\
**Post date:** [June 19, 2024, 8:04am UTC](https://forum.pritunl.com/t/compress-error-server-pushed-compression-settings-that-are-not-allowed/1584/6 "2024-06-19T08:04:33Z")

</div>

Perfect, thank you. `lzo_compression` is set to false so I’m not sure why the Android OpenVPN client is giving me `Transport Error: server pushed compression settings that are not allowed and will result in a non-working connection.`

---

<div class="post-metadata">

**Author:** ![mjaggard](https://forum.pritunl.com/user_avatar/forum.pritunl.com/mjaggard/32/413_2.png) [@mjaggard](https://forum.pritunl.com/u/mjaggard)\
**Post date:** [June 19, 2024, 8:44am UTC](https://forum.pritunl.com/t/compress-error-server-pushed-compression-settings-that-are-not-allowed/1584/7 "2024-06-19T08:44:00Z")

</div>

I’ve resolved the problem by selecting “Legacy” for the security configuration in the OpenVPN Connect app.

> **[Sophos Firewall: Temporary Fix OpenVPN (3.4.0) No Compression (Android...](https://community.sophos.com/sophos-xg-firewall/f/recommended-reads/143651/sophos-firewall-temporary-fix-openvpn-3-4-0-no-compression-android-devices)**
>
> Disclaimer: This information is provided as-is for the benefit of the Community. Please contact Sophos Professional Services if you require assistance with your
