# DNS issue with Pritunl client on Debian 12 Bookworm

**URL:** <https://forum.pritunl.com/t/dns-issue-with-pritunl-client-on-debian-12-bookworm/3759>\
**Category:** Pritunl VPN\
**Tags:** pritunl-client\
**Created:** [March 23, 2026, 2:10pm UTC](https://forum.pritunl.com/t/dns-issue-with-pritunl-client-on-debian-12-bookworm/3759 "2026-03-23T14:10:47Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![fabcor-maxiv](https://forum.pritunl.com/letter_avatar_proxy/v4/letter/f/d26b3c/32.png) [@fabcor-maxiv](https://forum.pritunl.com/u/fabcor-maxiv)\
**Post date:** [March 23, 2026, 2:10pm UTC](https://forum.pritunl.com/t/dns-issue-with-pritunl-client-on-debian-12-bookworm/3759/1 "2026-03-23T14:10:47Z")

</div>

It seems like there might be an issue related to DNS with the Pritunl client running on Debian 12 Bookworm.

This is what can be seen in the profile log for all clients from version [1.3.4269.93](https://github.com/pritunl/pritunl-client/releases/tag/1.3.4269.93) and upwards:

```none
Call failed: The name org.freedesktop.resolve1 was not provided by any .service files
<8>Mar 23 13:52:10 5e847c18ba2bae82-up.sh: 'busctl' exited with status 1
2026-03-23 13:52:10 WARNING: Failed running command (--up/--down): external program exited with error status: 1
2026-03-23 13:52:10 Exiting due to fatal error

```

The only way to establish a stable connection is to set the “_Disable DNS_” option, but then of course DNS resolution is not correct.

Pritunl client version [1.3.4262.38](https://github.com/pritunl/pritunl-client/releases/tag/1.3.4262.38) seems to work just fine.

---

<div class="post-metadata">

**Author:** ![zach](https://forum.pritunl.com/user_avatar/forum.pritunl.com/zach/32/1105_2.png) [@zach](https://forum.pritunl.com/u/zach)\
**Post date:** [March 23, 2026, 3:40pm UTC](https://forum.pritunl.com/t/dns-issue-with-pritunl-client-on-debian-12-bookworm/3759/2 "2026-03-23T15:40:05Z")

</div>

Run these commands to get the DNS configuration state.

```bash
sudo bash -x << 'EOF'
set -x
cat /etc/resolv.conf
cat /etc/resolvconf.conf
cat /etc/resolv.conf.bak
ls -la /etc/resolv.conf
resolvectl status
resolvectl dns
systemctl status systemd-resolved
resolvconf -l
NetworkManager --print-config | grep rc-manager
EOF

```

---

<div class="post-metadata">

**Author:** ![fabcor-maxiv](https://forum.pritunl.com/letter_avatar_proxy/v4/letter/f/d26b3c/32.png) [@fabcor-maxiv](https://forum.pritunl.com/u/fabcor-maxiv)\
**Post date:** [March 23, 2026, 5:30pm UTC](https://forum.pritunl.com/t/dns-issue-with-pritunl-client-on-debian-12-bookworm/3759/3 "2026-03-23T17:30:10Z")

</div>

Thanks for the quick reply.

Here is the requested output:

```none
+ set -x
+ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
# 127.0.0.53 is the systemd-resolved stub resolver.
# run "resolvectl status" to see details about the actual nameservers.

nameserver 192.168.1.1
search home
+ cat /etc/resolvconf.conf
cat: /etc/resolvconf.conf: No such file or directory
+ cat /etc/resolv.conf.bak
cat: /etc/resolv.conf.bak: No such file or directory
+ ls -la /etc/resolv.conf
lrwxrwxrwx 1 root root 29 May 16 2025 /etc/resolv.conf -> ../run/resolvconf/resolv.conf
+ resolvectl status
bash: line 6: resolvectl: command not found
+ resolvectl dns
bash: line 7: resolvectl: command not found
+ systemctl status systemd-resolved
Unit systemd-resolved.service could not be found.
+ resolvconf -l
# resolv.conf from NetworkManager
search home
nameserver 192.168.1.1
+ NetworkManager --print-config
+ grep rc-manager
# rc-manager=

```

---

<div class="post-metadata">

**Author:** ![zach](https://forum.pritunl.com/user_avatar/forum.pritunl.com/zach/32/1105_2.png) [@zach](https://forum.pritunl.com/u/zach)\
**Post date:** [March 23, 2026, 7:23pm UTC](https://forum.pritunl.com/t/dns-issue-with-pritunl-client-on-debian-12-bookworm/3759/4 "2026-03-23T19:23:22Z")

</div>

It looks like you have modified the system DNS configuration. The Pritunl client will look for `127.0.0.53` and `systemd-resolved` in the file `/etc/resolv.conf` to detect systemd-resolved. You have this in the file but `nameserver 192.168.1.1` indicates it is not actually using the systemd stub resolver. Deleting those commented lines at in the `/etc/resolv.conf` should correct the issue. I may make changes to the DNS code to detect this but the system resolv conf file should still be corrected.

---

<div class="post-metadata">

**Author:** ![fabcor-maxiv](https://forum.pritunl.com/letter_avatar_proxy/v4/letter/f/d26b3c/32.png) [@fabcor-maxiv](https://forum.pritunl.com/u/fabcor-maxiv)\
**Post date:** [March 24, 2026, 3:50pm UTC](https://forum.pritunl.com/t/dns-issue-with-pritunl-client-on-debian-12-bookworm/3759/5 "2026-03-24T15:50:19Z")

</div>

Thanks for the advice.

I do not recall making any change to DNS settings explicitly on this system, but maybe I did…

I am trying to figure out the sequence of events:

- Run `sudo apt-get --purge autoremove pritunl-client resolvconf`
- Remove network interfaces via GNOME GUI
- Power-cycle
- Diagnostics:

```none
+ set -x
+ cat /etc/resolv.conf
# Generated by NetworkManager
+ cat /etc/resolvconf.conf
cat: /etc/resolvconf.conf: No such file or directory
+ cat /etc/resolv.conf.bak
cat: /etc/resolv.conf.bak: No such file or directory
+ ls -la /etc/resolv.conf
-rw-r--r-- 1 root root 30 Mar 24 16:18 /etc/resolv.conf
+ resolvectl status
bash: line 6: resolvectl: command not found
+ resolvectl dns
bash: line 7: resolvectl: command not found
+ systemctl status systemd-resolved
Unit systemd-resolved.service could not be found.
+ resolvconf -l
bash: line 9: resolvconf: command not found
+ NetworkManager --print-config
+ grep rc-manager
# rc-manager=

```

- Add network interface via GNOME GUI
- Power-cycle
- Check network connectivity OK
- Diagnostics:

```none
+ set -x
+ cat /etc/resolv.conf
# Generated by NetworkManager
search home
nameserver 192.168.1.1
+ cat /etc/resolvconf.conf
cat: /etc/resolvconf.conf: No such file or directory
+ cat /etc/resolv.conf.bak
cat: /etc/resolv.conf.bak: No such file or directory
+ ls -la /etc/resolv.conf
-rw-r--r-- 1 root root 65 Mar 24 16:23 /etc/resolv.conf
+ resolvectl status
bash: line 6: resolvectl: command not found
+ resolvectl dns
bash: line 7: resolvectl: command not found
+ systemctl status systemd-resolved
Unit systemd-resolved.service could not be found.
+ resolvconf -l
bash: line 9: resolvconf: command not found
+ NetworkManager --print-config
+ grep rc-manager
# rc-manager=

```

- Run `sudo apt-get install pritunl-client` (installs latest available version, which also installs `resolvconf` as dependency, but not `systemd-resolved`)
- Power-cycle
- Diagnostics (note how comments have been added automatically):

```none
+ set -x
+ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
# 127.0.0.53 is the systemd-resolved stub resolver.
# run "resolvectl status" to see details about the actual nameservers.

nameserver 192.168.1.1
search home
+ cat /etc/resolvconf.conf
cat: /etc/resolvconf.conf: No such file or directory
+ cat /etc/resolv.conf.bak
cat: /etc/resolv.conf.bak: No such file or directory
+ ls -la /etc/resolv.conf
lrwxrwxrwx 1 root root 29 Mar 24 16:25 /etc/resolv.conf -> ../run/resolvconf/resolv.conf
+ resolvectl status
bash: line 6: resolvectl: command not found
+ resolvectl dns
bash: line 7: resolvectl: command not found
+ systemctl status systemd-resolved
Unit systemd-resolved.service could not be found.
+ resolvconf -l
# resolv.conf from NetworkManager
search home
nameserver 192.168.1.1
+ NetworkManager --print-config
+ grep rc-manager
# rc-manager=

```

- Connection attempt to VPN tunnel via `pritunl-client` fails with log:

```none
Call failed: The name org.freedesktop.resolve1 was not provided by any .service files
<8>Mar 24 16:30:14 ti35cbauojpbmi0h-up.sh: 'busctl' exited with status 1
2026-03-24 16:30:14 us=534846 WARNING: Failed running command (--up/--down): external program exited with error status: 1
2026-03-24 16:30:14 us=534855 Exiting due to fatal error

```

- Remove comments in `/etc/resolv.conf` so that it reads:

```none
nameserver 192.168.1.1
search home

```

- Connection attempt to VPN tunnel via `pritunl-client` succeeds and is stable
- Diagnostics while connected to VPN tunnel (note how comments are back):

```none
+ set -x
+ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
# 127.0.0.53 is the systemd-resolved stub resolver.
# run "resolvectl status" to see details about the actual nameservers.

nameserver REDACTED
nameserver REDACTED
nameserver 192.168.1.1
search REDACTED REDACTED home
+ cat /etc/resolvconf.conf
cat: /etc/resolvconf.conf: No such file or directory
+ cat /etc/resolv.conf.bak
cat: /etc/resolv.conf.bak: No such file or directory
+ ls -la /etc/resolv.conf
lrwxrwxrwx 1 root root 29 Mar 24 16:25 /etc/resolv.conf -> ../run/resolvconf/resolv.conf
+ resolvectl status
bash: line 6: resolvectl: command not found
+ resolvectl dns
bash: line 7: resolvectl: command not found
+ systemctl status systemd-resolved
Unit systemd-resolved.service could not be found.
+ resolvconf -l
# resolv.conf from tun0.vpn
search REDACTED REDACTED
nameserver REDACTED
nameserver REDACTED
# resolv.conf from NetworkManager
search home
nameserver 192.168.1.1
+ NetworkManager --print-config
+ grep rc-manager
# rc-manager=

```

- Disconnect from VPN tunnel
- Diagnostics:

```none
+ set -x
+ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
# 127.0.0.53 is the systemd-resolved stub resolver.
# run "resolvectl status" to see details about the actual nameservers.

nameserver 192.168.1.1
search home
+ cat /etc/resolvconf.conf
cat: /etc/resolvconf.conf: No such file or directory
+ cat /etc/resolv.conf.bak
cat: /etc/resolv.conf.bak: No such file or directory
+ ls -la /etc/resolv.conf
lrwxrwxrwx 1 root root 29 Mar 24 16:25 /etc/resolv.conf -> ../run/resolvconf/resolv.conf
+ resolvectl status
bash: line 6: resolvectl: command not found
+ resolvectl dns
bash: line 7: resolvectl: command not found
+ systemctl status systemd-resolved
Unit systemd-resolved.service could not be found.
+ resolvconf -l
# resolv.conf from NetworkManager
search home
nameserver 192.168.1.1
+ NetworkManager --print-config
+ grep rc-manager
# rc-manager=

```

- Attempt to connect to same VPN tunnel again fails with log:

```none
Call failed: The name org.freedesktop.resolve1 was not provided by any .service files
<8>Mar 24 16:45:27 ti35cbauojpbmi0h-up.sh: 'busctl' exited with status 1
2026-03-24 16:45:27 us=42847 WARNING: Failed running command (--up/--down): external program exited with error status: 1
2026-03-24 16:45:27 us=42857 Exiting due to fatal error

```

It feels to me like the comments in `/etc/resolv.conf` get added automatically. If I remove these comments manually, it is possible to establish a stable VPN connection, but the comments are added to `/etc/resolv.conf` and the subsequent attempt to connect to the VPN tunnel fails.

---

<div class="post-metadata">

**Author:** ![fabcor-maxiv](https://forum.pritunl.com/letter_avatar_proxy/v4/letter/f/d26b3c/32.png) [@fabcor-maxiv](https://forum.pritunl.com/u/fabcor-maxiv)\
**Post date:** [March 24, 2026, 5:43pm UTC](https://forum.pritunl.com/t/dns-issue-with-pritunl-client-on-debian-12-bookworm/3759/6 "2026-03-24T17:43:08Z")

</div>

As far as I understand, the header comment that gets added to `/etc/resolv.conf` by `resolvconf` comes from `/etc/resolvconf/resolv.conf.d/head`:

```none
$ cat /etc/resolvconf/resolv.conf.d/head
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
# 127.0.0.53 is the systemd-resolved stub resolver.
# run "resolvectl status" to see details about the actual nameservers.

```

I suppose I could edit `/etc/resolvconf/resolv.conf.d/head`, so that it does not contain the content that confuses `pritunl-client` in a manner that is more durable.

It appears that this comment was removed in newer versions of `resolvconf`:

> **[Remove the confusing comment about resolvectl from the resolv.conf header...](https://salsa.debian.org/debian/resolvconf/-/commit/a02f842b546a43ec2abe491e025a887940e62304)**
>
> Revert "etc/resolvconf/resolv.conf.d/head: add comment about 'systemd-resolve --status'" This reverts commit 41d178ec53125119a198a97bd4703744f122e53b. Closes: #1039696

following this issue report:

> **[\#1039696 - Confusing header message in /etc/resolvconf/resolv.conf.d/head -...](https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1039696)**

---

<div class="post-metadata">

**Author:** ![zach](https://forum.pritunl.com/user_avatar/forum.pritunl.com/zach/32/1105_2.png) [@zach](https://forum.pritunl.com/u/zach)\
**Post date:** [March 28, 2026, 8:29pm UTC](https://forum.pritunl.com/t/dns-issue-with-pritunl-client-on-debian-12-bookworm/3759/7 "2026-03-28T20:29:55Z")

</div>

The next release will adjust the systemd-resolved detection so that this will not occur.
