# Pritunl Client v1.3.3283.46

**URL:** <https://forum.pritunl.com/t/pritunl-client-v1-3-3283-46/381>\
**Category:** Releases\
**Tags:** pritunl-client\
**Created:** [September 8, 2022, 12:17pm UTC](https://forum.pritunl.com/t/pritunl-client-v1-3-3283-46/381 "2022-09-08T12:17:52Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![zach](https://forum.pritunl.com/user_avatar/forum.pritunl.com/zach/32/1105_2.png) [@zach](https://forum.pritunl.com/u/zach)\
**Post date:** [September 8, 2022, 12:17pm UTC](https://forum.pritunl.com/t/pritunl-client-v1-3-3283-46/381/1 "2022-09-08T12:17:52Z")

</div>

[**Pritunl Client v1.3.3283.46**](https://github.com/pritunl/pritunl-client-electron/releases/tag/1.3.3282.37) has been released. This release improves the display of error messages. The logs button has been moved to the top right menu and an option has been added to use the frameless window on macOS and Linux.

 ![pritunl_client_macos_frameless](https://forum-static.pritunl.com/original/1X/8ddcd63672960c4ba834981be7c9ecf7445707a0.png)

---

<div class="post-metadata">

**Author:** ![skulblock](https://forum.pritunl.com/letter_avatar_proxy/v4/letter/s/5f9b8f/32.png) [@skulblock](https://forum.pritunl.com/u/skulblock)\
**Post date:** [September 9, 2022, 4:48am UTC](https://forum.pritunl.com/t/pritunl-client-v1-3-3283-46/381/2 "2022-09-09T04:48:58Z")

</div>

We’re currently on v1.3.3283.46  
After upgrade from v1.2, we are unable to connect to the VPN server. The logs show:

```auto
<14>Sep 9 10:10:53 411d0d8c18f0cbafb385ed23076283be-up.sh: Adding IPv4 DNS Server 192.168.0.2
<14>Sep 9 10:10:53 411d0d8c18f0cbafb385ed23076283be-up.sh: SetLinkDNS(17 1 2 4 192 168 0 2)
e[0;1;31mCall failed: Unit dbus-org.freedesktop.resolve1.service not found.e[0m
<8>Sep 9 10:10:53 411d0d8c18f0cbafb385ed23076283be-up.sh: 'busctl' exited with status 1
Fri Sep 9 10:10:53 2022 WARNING: Failed running command (--up/--down): external program exited with error status: 1
Fri Sep 9 10:10:53 2022 Exiting due to fatal error

```

We dont use systemd resolved. We have our own DNS running locally. It was working fine until this upgrade was done.

---

<div class="post-metadata">

**Author:** ![skulblock](https://forum.pritunl.com/letter_avatar_proxy/v4/letter/s/5f9b8f/32.png) [@skulblock](https://forum.pritunl.com/u/skulblock)\
**Post date:** [September 9, 2022, 5:05am UTC](https://forum.pritunl.com/t/pritunl-client-v1-3-3283-46/381/3 "2022-09-09T05:05:09Z")

</div>

Update: if I do `sudo systemctl enable systemd-resolved` and then connect to the VPN using Pritunl client and then do `sudo systemctl disable systemd-resolved` everything works fine. This looks like an unnecessary dependency, we had issues with systemd-resolved in the past, hence we stopped using it and disabled it. I understand this is to push the custom DNS from server side, but if that is not happening, the connection shouldn’t break fully I feel.

---

<div class="post-metadata">

**Author:** ![zach](https://forum.pritunl.com/user_avatar/forum.pritunl.com/zach/32/1105_2.png) [@zach](https://forum.pritunl.com/u/zach)\
**Post date:** [September 9, 2022, 5:19am UTC](https://forum.pritunl.com/t/pritunl-client-v1-3-3283-46/381/4 "2022-09-09T05:19:36Z")

</div>

What Linux distribution and release version is that occurring on?

---

<div class="post-metadata">

**Author:** ![skulblock](https://forum.pritunl.com/letter_avatar_proxy/v4/letter/s/5f9b8f/32.png) [@skulblock](https://forum.pritunl.com/u/skulblock)\
**Post date:** [September 9, 2022, 5:23am UTC](https://forum.pritunl.com/t/pritunl-client-v1-3-3283-46/381/5 "2022-09-09T05:23:17Z")

</div>

I’m on Zorin 16.1. Its based on Ubuntu 20.04 LTS

---

<div class="post-metadata">

**Author:** ![zach](https://forum.pritunl.com/user_avatar/forum.pritunl.com/zach/32/1105_2.png) [@zach](https://forum.pritunl.com/u/zach)\
**Post date:** [September 13, 2022, 11:32pm UTC](https://forum.pritunl.com/t/pritunl-client-v1-3-3283-46/381/6 "2022-09-13T23:32:32Z")

</div>

I couldn’t reproduce this issue, check the logs listed in the [**client debugging**](https://docs.pritunl.com/docs/debugging-client). The profile log should have more information on the error occurring.

---

<div class="post-metadata">

**Author:** ![formerredbeard](https://forum.pritunl.com/letter_avatar_proxy/v4/letter/f/b5e925/32.png) [@formerredbeard](https://forum.pritunl.com/u/formerredbeard)\
**Post date:** [September 14, 2022, 8:50pm UTC](https://forum.pritunl.com/t/pritunl-client-v1-3-3283-46/381/7 "2022-09-14T20:50:51Z")

</div>

Zach,  
I like the general direction you are taking the look of the Client, however would it be possible to reduce all of the info for a server that a user is not connected to? Ie Show name of Server to connect to, the Connect OpenVPN, Connect WireGuard, Settings button and then perhaps an arrow like button to open a drop down to show more info about that connection instead of all of the other information on it. Also to **BOLD** the server Name would be helpful to set it apart from the rest of the info. Then it would be much easier for the users to scroll through the list to find the server to connect to / find the server they are connected to if it is not the first one on the list. Ideally the connected one would be reordered to the top, but that may be more difficult than it should be.
