Azure SSO Issue

We just signed up for the enterprise. Almost 100% just for the SSO :slight_smile:
I followed the steps (2 twice now) for setting up Azure SSO and get the same error.
I open an incognito mode, go to my URL, click “Sign in with Azure”
It spins for a bit and then comes to “pritunl-vpn’s server ip address could not be found”
Looking for a bit here, I see the url looks like this:

So I think I have something not configured correctly. But not sure what. A bit of explanation on my setup:

  1. to access the web url through the outside world I am going through nginx, and a non-standard port (https : // 444 )

I have tried restarting the server a few times, and I have tried rebuilding the secret keys and such.
I have found that if I put the WRONG secret key in, it will give me a different error. So it seems something is working.

Also, why is it we are pointing call backs to auth pritunl com and not our own server? Are you somehow in the middle of the callback system? wouldn’t that be an inherit security risk?


The Host header is used for the callback URL, the Nginx server may be modifying this. Single sign-on is handled through this protects the enterprise features. Duo can be added as an additional separate layer of authentication that is not handled through the Pritunl authentication servers.

Hi Zach,
That worked, it was the host header. Now we are running into an additional issue.
I will start a new thread for that!