Failed to connect using wireguard, fixed by manually editing the profile to change sync_host

My Pritunl web console is behind a reverse proxy and Cloudflare proxy. So, I set the public address to my server’s public IP. That then makes all config uses that ip for vpn remote, and sync host. The problem is, because I set it up as a reverse proxy, I set the port to 8008, and that port is blocked. But, by setting the sync host to my domain and setting remote to server public IP, it works fine. But, that means I have to edit every profile to use Wireguard. So, how do I set a different sync host than remote?

The sync address option is only shown in the hosts tab which requires an enterprise subscription. The sync address was repurposed for WireGuard connections and configuration sync is only available with a subscription so this option is not visible. You can use the command below to set this value from the MongoDB shell.

use pritunl
db.hosts.updateMany({}, {$set: {sync_address: ""}});

So in other words this sync address option is only available in the Enterprise version or is it possible to explicitly specify this value in mongodb as mentioned here (in usual -non Enterprise) and it will work?

The MongoDB shell commands above will set the sync address with or without a subscription.

and if mentioned command will set the sync address without subscription sync feature will work?

No the configuration sync will not work. The WireGuard connection that also utilizes the sync address will work.