Fresh Install of Pritunl on Ubuntu 20.04... missing tunnel device? How do I create one?

After tearing my hair out and finally getting pritunl and mongodb running (the pritunl webUI is fully functional), my current issue in the server log is:

2022-09-07 10:14:30 ERROR Management socket exception

which I beleive is due to the fact that the ubuntu 20 server instance this is running on has no tun device.

I ran

sudo mkdir -p /dev/net
sudo mknod /dev/net/tun c 10 200
sudo chmod 600 /dev/net/tun

from ERROR Management socket exception

but theres still no tun device in ip a output after a restart
I have no idea how to use netplan (I previously was use to /etc/networking/interfaces) and google isnt giving me any results that make sense to me…

How the heck do I add a tunnel device in ubuntu 20?

(tried posting on reddit too)

thanks for reading!

Check the log files listed in the debugging documentation

1 Like

thanks for the link- but im unable to get client access at all, so I was refferring to the server side log:

edit: I do see this in the terminal log output which i think is just the result of pritunl trying to use a tun0 that is not present…

[winter-waves-6815][2022-09-07 10:14:40,540][ERROR] Error in management socket thread
Traceback (most recent call last):
  File "/usr/lib/pritunl/lib/python3.8/site-packages/pritunl/server/", line 286, in _socket_thread
  File "/usr/lib/pritunl/lib/python3.8/site-packages/pritunl/server/", line 372, in connect
ConnectionRefusedError: [Errno 111] Connection refused
  server_id   = "6317199e4a0ff4ee08c8d5b1"
  instance_id = "63186f10746ff8feb72e9b11"
  socket_path = "/var/run/pritunl_63186f10746ff8feb72e9b11.sock"

If you are still looking for an answer, this seems to have worked for me, I have not tested it much, yet.

shut down the container

add the following lines to the container config file, if they do not already exist:

features: nesting=1
lxc.cgroup2.devices.allow: c 10:200 rwm
lxc.mount.entry: /dev/net dev/net none bind,create=dir

On the physical proxmox host, run:
chown 100000:100000 /dev/net/tun

start the container, and hopefully things will work.

1 Like

I ended up having to reinstall pritunl…

Changed perms on the tun device to 755 and apt --purge autoremove pritunl then reinstalled. servers working now as expected :man_shrugging: I think it was just the reinstall that did it honestly…