No GUI app available after pritunl-client-electron installation

I have installed pritunl client electron using the official documentation mentioned in below link on Ubunutu 20.04

the installation was complete with no error. But i cannot see any app in my ubuntu software. I have received .ovpn file from client which i need to import to access the server. There is no log folder in /var/log/ as well so that i can see any error. Running ‘pritunl-client-electron’ command on terminal says ‘pritunl-client-electron: command not found’.

1 Like

same here, both on ubuntu 20 and 22, after install of the latest version, no GUI was present and no browser popup from the CLI

I can’t reproduce this issue on Ubuntu 20.04. The .desktop file which registers applications shown in the menu is located at /usr/share/applications/pritunl-client-electron.desktop the command to start the client is /usr/lib/pritunl_client_electron/Pritunl. The application will sometimes be shown on the next page and require scrolling to access.

zsh: permission denied: /usr/lib/pritunl_client_electron/Pritunl

sudo /usr/lib/pritunl_client_electron/Pritunl
[1207/] Running as root without --no-sandbox is not supported. See 638180 - chromium - An open-source project to help move the web forward. - Monorail.

It’s something wrong with permissions

Press alt+f2 and run /usr/lib/pritunl_client_electron/Pritunl

same issue here also, tried in different systems.

I had a running pritunl app with the latest version after upgrading, but to replicate the issue a colleague had, I’ve purged pritunl and install the latest version. Then I had no GUI and the CLI did not open the browser for SSO. We had to downgrade to version v1.3.3343.50 to have it working

Well, I can’t downgrade it on Arch

sudo downgrade 'pritunl-client-electron=1.3.3343.50'


No results found
Unable to downgrade pritunl-client-electron

it can only downgrade to cached version. But this is a fresh Arch install, I do not have it in cache :frowning:

Previous releases are available from the GitHub Repository.

I have reproduced the issue. It can be fixed by running the commands below to fix the directory permissions. Then run the other commands to refresh the menu to allow the Pritunl icon to be shown.

sudo chmod 755 /usr/lib/pritunl_client_electron
sudo gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor || true
sudo xdg-icon-resource forceupdate --theme hicolor || true
sudo update-desktop-database -q || true
1 Like

Thanks, so it was only 755 that needed to be set? :smiley:
I was losing my mind about this for few days.

This has been fixed in a rebuild of v1.3.3373.6 with release number 2.

1 Like

thanks a lot changing the permission as suggested by zach worked