No link-mtu in generated client configs

We trying to set up pritunl-server in network, where PMTU not works. So i am trying to lower tun-mtu to valid value for this network.

It worked for tun0 on pritunl server, but not for clients:
2024-05-29 13:36:31 WARNING: ‘link-mtu’ is used inconsistently, local=‘link-mtu 1572’, remote=‘link-mtu 1490’
2024-05-29 13:36:31 WARNING: ‘tun-mtu’ is used inconsistently, local=‘tun-mtu 1500’, remote=‘tun-mtu 1418’

If i am manually set mtu=1418 on tun on client (ip link set tun0 mtu 1418) everything works as expected, but there are no anything about tun-mtu or something else in client .ovpn file

On host installed pritunl=1.32.3805.95-0ubuntu1~focal (however we have mixed versions cluster, because now we testing latest version on this host), client configs downloaded from that server

That happenes bot for tcp/udp openvpn server

Enterprise license used

It shouldn’t need to be set in both the client and server configuration. I will look into adding it into the client configuration to fix any issues that are occurring.

Will take more tests before giving further info, sorry.

Anyway, i understood, that it is not common case to be connected to networks with non-default MTU + broken path-MTU, so it is definetely have not to be default option.
Looks like “client MTU” field per-server is ok