Pritunl can't connect to mongodb or something

hello i’m trying to run pritunl on WSL

when i ‘sudo pritunl’ i get this

[undefined][2022-04-19 00:25:00,329][ERROR] Error connecting to mongodb server
Traceback (most recent call last):
File “/usr/lib/pritunl/lib/python3.8/site-packages/pritunl/setup/server.py”, line 288, in setup_server
utils.get_db_ver_int()
File “/usr/lib/pritunl/lib/python3.8/site-packages/pritunl/utils/misc.py”, line 98, in get_db_ver_int
return get_int_ver(get_db_ver())
File “/usr/lib/pritunl/lib/python3.8/site-packages/pritunl/utils/misc.py”, line 90, in get_db_ver
return _get_version_doc().get(‘version’) or (
File “/usr/lib/pritunl/lib/python3.8/site-packages/pritunl/utils/misc.py”, line 80, in _get_version_doc
doc = settings_db.find_one({
File “/usr/lib/pritunl/lib/python3.8/site-packages/pymongo/collection.py”, line 1328, in find_one
for result in cursor.limit(-1):
File “/usr/lib/pritunl/lib/python3.8/site-packages/pymongo/cursor.py”, line 1238, in next
if len(self.__data) or self._refresh():
File “/usr/lib/pritunl/lib/python3.8/site-packages/pymongo/cursor.py”, line 1130, in _refresh
self.__session = self.__collection.database.client._ensure_session()
File “/usr/lib/pritunl/lib/python3.8/site-packages/pymongo/mongo_client.py”, line 1935, in _ensure_session
return self.__start_session(True, causal_consistency=False)
File “/usr/lib/pritunl/lib/python3.8/site-packages/pymongo/mongo_client.py”, line 1883, in __start_session
server_session = self._get_server_session()
File “/usr/lib/pritunl/lib/python3.8/site-packages/pymongo/mongo_client.py”, line 1921, in _get_server_session
return self._topology.get_server_session()
File “/usr/lib/pritunl/lib/python3.8/site-packages/pymongo/topology.py”, line 520, in get_server_session
session_timeout = self._check_session_support()
File “/usr/lib/pritunl/lib/python3.8/site-packages/pymongo/topology.py”, line 499, in _check_session_support
self._select_servers_loop(
File “/usr/lib/pritunl/lib/python3.8/site-packages/pymongo/topology.py”, line 218, in _select_servers_loop
raise ServerSelectionTimeoutError(
pymongo.errors.ServerSelectionTimeoutError: localhost:27017: [Errno 111] Connection refused, Timeout: 30s, Topology Description: <TopologyDescription id: 1234567890abcdfe12345678, topology_type: Single, servers: [<ServerDescription (‘localhost’, 27017) server_type: Unknown, rtt: None, error=AutoReconnect(‘localhost:27017: [Errno 111] Connection refused’)>]>

what did i do wrong? how to fix?

thank you for your time

It’s unlikely a Pritunl server will run on Windows. The WSL distributions don’t support systemd, that is preventing the MongoDB server from correctly starting.

Please help, I encountered the same problem on Ubuntu 22, after installation on a clean system, Pritunl works for 24 hours, in a day it stops starting, even after restarting.

When I try to run manually, I get the following code:

root@vm534170:~# pritunl start ############################################################## # # # /$$ /$$ /$$ # # |/ | $$ | $$ # # /$$$$$$ /$$$$$$ /$$ /$$$$$$ /$$ /$$ /$$$$$$$ | $$ # # /$$ $$ /$$__ $$| $$|_ $$/ | $$ | $$| $$__ $$| $$ # # | $$ \ $$| $$ \__/| $$ | $$ | $$ | $$| $$ \ $$| $$ # # | $$ | $$| $$ | $$ | $$ /$$| $$ | $$| $$ | $$| $$ # # | $$$$$$$/| $$ | $$ | $$$$/| $$$$$$/| $$ | $$| $$ # # | $$/ |/ |/ \/ \/ |/ |/|/ # # | $$ # # | $$ # # |_/ # # # ############################################################## [undefined][2023-03-17 22:26:47,094][ERROR] Error connecting to mongodb server Traceback (most recent call last): File “/usr/lib/pritunl/lib/python3.10/site-packages/pritunl/setup/server.py”, line 288, in setup_server utils.get_db_ver_int() File “/usr/lib/pritunl/lib/python3.10/site-packages/pritunl/utils/misc.py”, line 101, in get_db_ver_int return get_int_ver(get_db_ver()) File “/usr/lib/pritunl/lib/python3.10/site-packages/pritunl/utils/misc.py”, line 93, in get_db_ver return _get_version_doc().get(version) or ( File “/usr/lib/pritunl/lib/python3.10/site-packages/pritunl/utils/misc.py”, line 83, in _get_version_doc doc = settings_db.find_one({ File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/collection.py”, line 1328, in find_one for result in cursor.limit(-1): File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/cursor.py”, line 1238, in next if len(self.__data) or self._refresh(): File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/cursor.py”, line 1130, in _refresh self.__session = self.__collection.database.client._ensure_session() File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/mongo_client.py”, line 1935, in _ensure_session return self.__start_session(True, causal_consistency=False) File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/mongo_client.py”, line 1883, in __start_session server_session = self._get_server_session() File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/mongo_client.py”, line 1921, in _get_server_session return self._topology.get_server_session() File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/topology.py”, line 520, in get_server_session session_timeout = self._check_session_support() File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/topology.py”, line 499, in _check_session_support self._select_servers_loop( File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/topology.py”, line 218, in _select_servers_loop raise ServerSelectionTimeoutError( pymongo.errors.ServerSelectionTimeoutError: localhost:27017: [Errno 111] Connection refused, Timeout: 30s, Topology Description: ]>

At the same time, I have 4 more servers from other providers and everything has been working perfectly there for a year. here I put it for the first time the day before yesterday and stops working a day later

Found the code, entered it, but got an error again

I really need your help

root@vm534170:~# sudo pritunl repair-database
[undefined][2023-03-17 22:43:33,751][ERROR] Pritunl setup failed
Traceback (most recent call last):
File “/usr/lib/pritunl/lib/python3.10/site-packages/pritunl/setup/init.py”, line 80, in setup_db
setup_mongo()
File “/usr/lib/pritunl/lib/python3.10/site-packages/pritunl/setup/mongo.py”, line 347, in setup_mongo
app_settings = settings_col.find_one({‘_id’: ‘app’})
File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/collection.py”, line 1328, in find_one
for result in cursor.limit(-1):
File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/cursor.py”, line 1238, in next
if len(self.__data) or self._refresh():
File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/cursor.py”, line 1130, in _refresh
self.__session = self.__collection.database.client._ensure_session()
File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/mongo_client.py”, line 1935, in _ensure_session
return self.__start_session(True, causal_consistency=False)
File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/mongo_client.py”, line 1883, in __start_session
server_session = self._get_server_session()
File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/mongo_client.py”, line 1921, in _get_server_session
return self._topology.get_server_session()
File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/topology.py”, line 520, in get_server_session
session_timeout = self._check_session_support()
File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/topology.py”, line 499, in _check_session_support
self._select_servers_loop(
File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/topology.py”, line 218, in _select_servers_loop
raise ServerSelectionTimeoutError(
pymongo.errors.ServerSelectionTimeoutError: localhost:27017: [Errno 111] Connection refused, Timeout: 30.0s, Topology Description: <TopologyDescription id: 6414c2c7baa355bbe376c62b, topology_type: Single, servers: [<ServerDescription (‘localhost’, 27017) server_type: Unknown, rtt: None, error=AutoReconnect(‘localhost:27017: [Errno 111] Connection refused’)>]>
Traceback (most recent call last):
File “/usr/bin/pritunl”, line 33, in
sys.exit(load_entry_point(‘pritunl==1.30.3354.99’, ‘console_scripts’, ‘pritunl’)())
File “/usr/lib/pritunl/lib/python3.10/site-packages/pritunl/main.py”, line 342, in main
setup.setup_db()
File “/usr/lib/pritunl/lib/python3.10/site-packages/pritunl/setup/init.py”, line 80, in setup_db
setup_mongo()
File “/usr/lib/pritunl/lib/python3.10/site-packages/pritunl/setup/mongo.py”, line 347, in setup_mongo
app_settings = settings_col.find_one({‘_id’: ‘app’})
File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/collection.py”, line 1328, in find_one
for result in cursor.limit(-1):
File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/cursor.py”, line 1238, in next
if len(self.__data) or self._refresh():
File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/cursor.py”, line 1130, in _refresh
self.__session = self.__collection.database.client._ensure_session()
File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/mongo_client.py”, line 1935, in _ensure_session
return self.__start_session(True, causal_consistency=False)
File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/mongo_client.py”, line 1883, in __start_session
server_session = self._get_server_session()
File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/mongo_client.py”, line 1921, in _get_server_session
return self._topology.get_server_session()
File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/topology.py”, line 520, in get_server_session
session_timeout = self._check_session_support()
File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/topology.py”, line 499, in _check_session_support
self._select_servers_loop(
File “/usr/lib/pritunl/lib/python3.10/site-packages/pymongo/topology.py”, line 218, in _select_servers_loop
raise ServerSelectionTimeoutError(
pymongo.errors.ServerSelectionTimeoutError: localhost:27017: [Errno 111] Connection refused, Timeout: 30.0s, Topology Description: <TopologyDescription id: 6414c2c7baa355bbe376c62b, topology_type: Single, servers: [<ServerDescription (‘localhost’, 27017) server_type: Unknown, rtt: None, error=AutoReconnect(‘localhost:27017: [Errno 111] Connection refused’)>]>

The database is likely not running. Run sudo systemctl status mongod. This may be related to a recent update, try downgrading to the versions shown in the current issues documentation. The commands in the documentation are only for RHEL.