Pritunl Client auto start on Ubuntu Server 22.04

Is there a way to configure the Pritunl Client to auto start and login when a server starts?

We’re using Ubuntu Server 22.04.

pritunl-client enable + id

We require a PIN in our environment. Is there a way to pass the PIN to the client when it auto starts?

that is the exact same issue I have in my side. I cant find any way to pass the PIN to start … the docs say nothing about the PIN… only a password that does not substitute the pin as I have test. I spent a good amount of time yesterday trying to find out how to give the pin on the commend line.

found something interesting. if you reboot the server the connection will be stablish with out asking for the pin as long as the profile is “enable” on the client arguments.

by the time I noticed that I already had the openvpn client configured and working. has way more documentation than pritnl client.

Looks like there is a way to pass in the PIN.

 pritunl-client start  provile_id -p password

This worked for me; however, I can’t seem to fine the option to disable the default gateway

yeah that also worked form me

pritunl-client start --password 11111 b829rfampxlceqbn --mode wg

I tried that before but didn’t work. now it did

I am getting this conclusions so far

  1. in order to make the client to work you need to install wireguard-tools apart from the PRITUNL itself
  2. only manual connection works as far as you pass the --password argument but not on OS boot as there is nowhere to store the password that I can find
  3. Ones WG tunnels are created they do not route to other peers. seems like is the gateway you mention. This is not the case when using OpenVPN.

hmm… I’m using Ubuntu 22.04 server and v1.3.3484.2 of the Pritunl Client.

I did the following and it seems to work. The client auto-starts after a reboot and connects automatically.

pritunl-client enable profile_id
pritunl-client start  profile_id -p password

I did not have to install wireguard-tools.
My only problem now is trying to figure out a way to disable the default route, which is mentioned in this post.

I tried 3 fresh new servers and the only way I could connect via WG was installing the wireguard-tools after the client install

there is other problem I was not able to solve, that is the re-connect. If you disable the tunnel, the client wont reconnect.

I gave up on this client. OpenVPN client is easy to install and reconnects very fast after connection drops. is not WG but works.

The commands are similar to systemd. The enable/disable commands will control the auto start and start/stop commands activate or deactivate the connection.