Pritunl clients connects without 2-factor

We have enabled Google Authenticator in Pritunl server. However, the client asks for the 2-factor every 3-4 days and not every time we want to connect to VPN. We couldn’t find any setting to disable 2-factor cache and override this behavior. Is this a bug or a misconfig from our end?

The options are in the top right settings. The commands shown in the two-factor authentication cache documentation will allow customizing the cache timeout.