Routing not working for Peered VPC

I’m using open source Pritunl doing initial POC. We have to VPC which is paired. In one VPC I have installed Pritunl and another one have multiple Instance. From Pritunl Instance I can reach to Instance in another VPC. I have configured Pritunl for additional route which is CIDR of another VPC. But I’m unable to reach instance in other VPC when connected through Pritunl vpn on my device.

I’m getting Operation timed out for port 22 for instance in VPC A while same instance is reachable from Pritunl instance. How I can debug this issue?

Screenshot 2023-01-27 at 11.12.53 PM

Please help on this or any help doc if I’m missing something.

I will explain issue to clear any confusion.

VPC A – My Prod VPC
VPC B – Pritunl VPC
Both A and B VPC is peered. I can SSH VPC A instance from Pritunl Instance to check VPC peering and ssh works.
I have added VPC A route in Pritunl route but SSH is not working when connected using Pritunl, I get Connection Timeout while doing SSH. Is this feature available in Enterprise plan?

This should work as long as NAT is used for the routes. Verify the firewall is configured correctly.

Hi Zach,

Thanks for reply. While adding route I don’t see NAT option, attaching screenshot for same.

I have tried testing after disabling source/des check at Pritunl Instance in AWS and adding route still no difference.

NAT can only be disabled with a subscription. If the server has never had a subscription the routes will all have NAT enabled.