Unable to Install Client on Arch Linux

Hello! I tried to install the pritunl-client on Arch Linux, as per the documentation found here

All the commands worked correclty, added the key and the repository, but the last command does not work:

sudo pacman -S pritunl-client-electron

This package apparently does not exist. If I type only pritunl and hit tab for autocompletion, the only packages available are:

pritunl             pritunl-endpoint    pritunl-link        pritunl-ndppd       pritunl-ssh         pritunl-ssh-host    pritunl-strongswan  pritunl-zero

Accessing the repository provided in the install instructions, the pritunl-client-electron seems to be missing there as well: Index of /stable/pacman/

1 Like

Managed to install it in a very roundabout way, using Nix package manager

Then after that, just had to add to PATH the $HOME/.nix-profile/bin directory and execute both the pritunl-client-service and pritunl-client-electron binaries, worked like a charm.

However my original question still persists. Is there any problem with the official pritunl repository?

The ArchLinux builds have been failing, once the issue is fixed the package will be added again.


Thanks for replying! Nice to know its being looked at.

It seems pritunl-client-electron-git works from the AUR. Only missing a dependency: go (pacman -S go).

This should be fixed now, it was only on the unstable repository. The stable repository now has the Arch Linux client packages, this may require clearing the cache.